Cisco PPPoE Configuration

  • by

Cisco PPPoE Configuration

ip name-server 15.15.15.1
!
ip dhcp pool 10
network 172.16.100.0 255.255.255.0
!
username cisco password 0 sisco

!
!
bba-group pppoe 1
virtual-template 1
!
!
interface FastEthernet0/0
no ip address
speed auto
!

interface FastEthernet0/0.1
encapsulation dot1Q 504
ip address 172.16.200.1 255.255.255.0
pppoe enable group 1

!

interface FastEthernet0/0.2
encapsulation dot1Q 502
ip address 15.15.15.130 255.255.255.252
ip nat outside

!

interface Virtual-Template1
ip address 172.16.100.1 255.255.255.0
ip nat inside
peer default ip address dhcp-pool 10
!

ip default-gateway 15.15.15.129
ip nat pool mypool 15.15.15.129 15.15.15.130 netmask 255.255.255.252
ip nat inside source list 1 pool mypool overload
ip classless
ip route 0.0.0.0 0.0.0.0 15.15.15.129
no ip http server

!
!
access-list 1 permit 172.16.100.0 0.0.0.255
!

 

#show ip interface brief
#show pppoe session
#show pppoe summury

Leave a Reply